Issue with phpMyAdmin after Using the Ctrl+F Keyboard Shortcut

While cleaning up database entries using phpMyAdmin, I ran into an issue after using the Ctrl+F keyboard shortcut. Something about the shortcut modifies the functionality of the arrow keys within phpMyAdmin. For example, when the text cursor is in a textarea form field, the arrow keys usually move the cursor around in that field. However, after using the shortcut, the arrow keys now jump between the different form fields for editing a database record. Luckily, there is a quick way to restore the normal functionality of the arrow keys, at least until the Ctrl+F shortcut is used again.


I noticed the issue when removing duplicate lines of text from a database record. To hasten the process, I used Google Chrome's built-in search feature to locate the duplicates. This was accomplished by selecting the text I wanted to use in the search (see Figure 1).

phpMyAdmin screenshot showing the selected search text

Figure 1. Select text for the search

Pressing Ctrl+F then opens the browser's search feature, populates the search field, runs the search, and highlights all the matching / duplicate lines (see Figure 2).

Screenshot showing how the browser's search feature highlights all the duplicates

Figure 2. Search feature highlights all the duplicates

However, when I click back into the form field to remove the duplicates, the arrow keys no longer move the text cursor around. Instead, the arrow keys now cause the text cursor to jump between the various form fields on the page. Pushing the up arrow, for example, causes the text cursor to jump to the previous form field (see Figure 3).

phpMyAdmin screenshot showing the up arrow on the keyboard moves the text cursor

Figure 3. Text cursor moved by the up arrow key

This problem appears to be related to phpMyAdmin itself. I currently use Windows 10 and the issue happens in Google Chrome, Mozilla Firefox, and Microsoft Edge. I tried a number of things to fix the issue, including closing the browser search feature, clicking the Go button in phpMyAdmin to submit the record changes, and then going back to the edit screen for the same record. Nothing seemed to work, other than closing the browser window and opening a new one, which got a little tedious.

Quick Solution

I don't know of a permanent solution for this problem. However, there is a quick way to restore the functionality of the arrow keys. After using the Ctrl+F shortcut, all you need to do is place the text cursor into one of the phpMyAdmin form fields and hit the Ctrl key.


There are currently no comments.

Leave a Comment